TravcoForum.com

Travco Classic Motorhome Support & Discussion Forum

Skip to content

Change font size

Board index » Maintenance » Brakes
Post here for Brake System related Discussion

No brakes at all in '68 270

Unread postby mabrandes on Fri Aug 26, 2016 5:43 pm

Now that I have the motor running... time to focus on the brakes... of which I have none. The MC was replaced in 1980. It was empty of fluid.. so I added some in. Pedal just goes to floor, no resistance at all. I'm reading service manual but would love to here any thoughts. Do I need pull MC and bench bleed it?

I also found a spring hanging loose from the pedal mechanism that I can't see an obvious place to attach the other end.
You do not have the required permissions to view the files attached to this post.
Matthew,
Wellsville, KS

1968 Dodge Travco 270 | 2010 Teardrop | 1966 & 1968 Utopia Pan-O-Ramic TT's | 1950 Spartan Royal Mansion | 1969 Arisocrat LoLiner |1964 Barth TT
mabrandes
New Member
New Member
 
Posts: 15
Joined: Thu Aug 11, 2016 9:19 pm
Location: Wellsville, KS
Travco Model: 1968 Travco 270

Re: No brakes at all in '68 270

Unread postby Acesneights on Fri Aug 26, 2016 8:07 pm

How long did the Travco sit ?
1975 Travco 270
1974 Travco 220 Parts unit
User avatar
Acesneights
Site Admin
Site Admin
 
Posts: 1755
Joined: Tue Jan 22, 2013 7:01 am
Location: North East Ct
Travco Model: 1975 270,1974 220

Re: No brakes at all in '68 270

Unread postby mabrandes on Fri Aug 26, 2016 9:21 pm

Acesneights wrote:How long did the Travco sit ?


Not sure last time it was driven. At least 2 years as tat is how long it was sitting at corner for sale. I'm going to bleed the brake system aND see how far I get.

Is there anyway to test hydro vacuum brake boosters first? I assume if they need rebuilt that would require the system to be bled again.
Matthew,
Wellsville, KS

1968 Dodge Travco 270 | 2010 Teardrop | 1966 & 1968 Utopia Pan-O-Ramic TT's | 1950 Spartan Royal Mansion | 1969 Arisocrat LoLiner |1964 Barth TT
mabrandes
New Member
New Member
 
Posts: 15
Joined: Thu Aug 11, 2016 9:19 pm
Location: Wellsville, KS
Travco Model: 1968 Travco 270

Re: No brakes at all in '68 270

Unread postby 77Travco on Mon Aug 29, 2016 7:17 am

Try bleeding first. Wheel cylinders will almost certainly need to be replaced but you wont know until bleeding and testing each wheel for braking ability and leakage.
User avatar
77Travco
Moderator
Moderator
 
Posts: 1146
Joined: Sat Jan 26, 2013 2:32 am
Location: Kerrville, Texas
Travco Model:

Re: No brakes at all in '68 270

Unread postby mabrandes on Mon Aug 29, 2016 8:11 am

77Travco wrote:Try bleeding first. Wheel cylinders will almost certainly need to be replaced but you wont know until bleeding and testing each wheel for braking ability and leakage.


Someone else mentioned wheel cylinders, so I may just proactively replace them.
Matthew,
Wellsville, KS

1968 Dodge Travco 270 | 2010 Teardrop | 1966 & 1968 Utopia Pan-O-Ramic TT's | 1950 Spartan Royal Mansion | 1969 Arisocrat LoLiner |1964 Barth TT
mabrandes
New Member
New Member
 
Posts: 15
Joined: Thu Aug 11, 2016 9:19 pm
Location: Wellsville, KS
Travco Model: 1968 Travco 270

Re: No brakes at all in '68 270

Unread postby Acesneights on Wed Aug 31, 2016 4:00 pm

mabrandes wrote:
Acesneights wrote:How long did the Travco sit ?


Not sure last time it was driven. At least 2 years as tat is how long it was sitting at corner for sale. I'm going to bleed the brake system aND see how far I get.

Is there anyway to test hydro vacuum brake boosters first? I assume if they need rebuilt that would require the system to be bled again.

Correct. You could pull the vac lines off and see if there is any brake fluid in them.
1975 Travco 270
1974 Travco 220 Parts unit
User avatar
Acesneights
Site Admin
Site Admin
 
Posts: 1755
Joined: Tue Jan 22, 2013 7:01 am
Location: North East Ct
Travco Model: 1975 270,1974 220


Return to Brakes

Who is online

Users browsing this forum: No registered users and 2 guests